Install Pidgin in Ubuntu

Sure, there are some posts on the Ubuntu Forums with links on how to install a deb package of Pidgin from some untrusted repository. Personally, I'm not too thrilled about using a package that hasn't gone through the community process of being added to Ubuntu. So I have two goals:

  1. Install Pidgin
  2. Show you how to install something from source

Don't be afraid by that last point--a few months ago I was too, but there is no reason to be afraid, because in 7 commands/15 minutes you are going to have Pidgin on your system.

Get the dependencies

Compiling from source does not get all the dependencies like apt-get does, but luckily I will tell you. From the command line type:

sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev

Additionally, if you want spell checking, include libgtkspell-dev in that list. Get the source: In my case 2.0.1 was the latest code, so check out the download page just to make sure. If there is a newer version, download that source version and skip this step:


Now unpack it:

tar xvfj pidgin-2.0.1.tar.bz2
cd pidgin-2.0.1

Configure and Install

Now the part that will take a few minutes between each command.

sudo make install


You installed the latest IM client! Now, you have to remember that it is your responsibility to reinstall anytime a newer version comes out, apt-get will not do it for you. So do this until Ubuntu backports Pidgin or until you upgrade to Gutsy Gibbon.


If you you get an error message like:

configure: error:

You must have the GTK+ 2.0 development headers installed to compile Pidgin.
If you only want to build Finch then specify --disable-gtkui when running configure.

then make sure you installed the dependencies:

sudo apt-get install libgtk2.0-dev

Or if you get:

configure: error:

You must have libxml2 >= 2.6.0 development headers installed to build.

Same thing, install the dependencies:

sudo apt-get install libxml2-dev

Thanks to amosharper for catching this one:

configure: error:

The msgfmt command is required to build libpurple.  If it is installed on your system, ensure that it is in your path.  If it is not, install GNU gettext to continue.

Again, install the dependencies:

sudo apt-get install gettext

Additionally, if you are getting a warning at the end of configuration that MSN and Google will not work, or if they simple do not work, make sure you have the last two dependencies:

SSL Library/Libraries......... : None (MSN and Google Talk will not work
without SSL!)

Again, install the dependencies:

sudo apt-get install libnss-dev libnspr-dev

Do you want spell checking? If so, you should install libgtkspell-dev with apt-get, then rerun the configure/make/sudo make install.